注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

Nihui's Blog

nihui的私人空间和日志

 
 
 

日志

 
 

适用于 Qt 4.4.x 的中文伪粗体补丁  

2008-05-31 10:55:21|  分类: Qt related |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |
最初的原型是 cjacker 做的。
原先有用于 Qt 4.3.x 的补丁,但是 Qt 4.4.x 上面用不了,这次是通过手工修改得到的补丁。

qt-4.4.0-use-ft_glyph_embolden-to-fake-bold.patch
qt4-4.4.0-add-missing-bold-style.patch

补丁已经提交给上游开发人员了,但愿下个版本或者下下个版本能用进去。

一个很重要的特性改善,原先 Qt 4.4.x 没法用中文的粗体...............  <--- 几乎所有的中文字体。

网易把图片弄小了................  适用于 Qt 4.4.x 的中文伪粗体补丁 - nihui - Nihuis Blog
实际效果:(未使用圆滑边角)

适用于 Qt 4.4.x 的中文伪粗体补丁 - nihui - Nihuis Blog


使用圆滑边角以后:

适用于 Qt 4.4.x 的中文伪粗体补丁 - nihui - Nihuis Blog
  评论这张
 
阅读(629)| 评论(0)
推荐 转载

历史上的今天

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2017